Expresiones en PSeint: Operados y Funciones Matemáticas

Todas las expresiones que podemos encontrar en Pseint se dividirán en dos partes: Por un lado tenemos los operadores y por otro las funciones.

Los dos conceptos anteriores  son parte esencial en el desarrollo de algoritmos y son pilares  para todo estudiante que inicia en fundamentos de programación; ya que le serán de gran ayuda para entender situaciones problema un poco más complejas.

Si estás iniciando en el estudio del pseudolenguaje que ofrece Pseint, o por algún motivo no conoces todos los operadores o funciones que se establecen en este software, este artículo es para ti.

Configurando PSeint  y entendiendo su Interfaz Gráfica

Antes de iniciar con nuestros proyectos, es importante lograr configurar nuestro Pseint de manera asertiva. Esto se logra a través de la configuración del perfil estricto, el cual es el que aconsejamos en la medida que es importante que los futuros programadores entiendan y se adapten al uso del punto y coma.

Por otra parte, dentro de la interfaz gráfica contamos con una barra superior, los iconos funcionales debajo de esta barra superior  y las barras laterales en las que podemos reconocer: las variables a usar, hacer uso de los operadores en general, lograr un paso a paso de nuestro proyecto y  lo más importante, tener a la mano los comandos y estructuras.

A continuación veremos un video de como lograr la configuración estricta de PSeint y a su vez entender la interfaz gráfica.

 

¿Qué operadores encontramos en PSeint?

El pseudocódigo establecido por la herramienta de desarrollo Pseint nos brinda el uso de una serie de operadores que pueden llegar a servir para implementar situaciones sencillas y algo complejas.

Por otra parte, es necesario destacar que la jerarquía de operaciones que se establece con los operadores es similar a la establecida en el álgebra y que esta puede llegar a ser cambiada con el uso de paréntesis.

La división de los operadores se establece como:

  • Operadores Relacionales
  • Operadores Lógicos
  • Operadores Algebraicos 

A continuación encontrarás una tabla resumida de los tipos de operador con su símbolo empleado en Pseint, su significado y un ejemplo preciso.

operadores y funciones en Pseint

¿Qué tipo de funciones podemos usar en Pseint?

Aparte de los operadores que vimos anteriormente, el pseudocódigo también hace uso de funciones matemáticas y estas se usan de forma similar que otros lenguajes de programación.

La forma en que se escriben las funciones en PSeint obedece a colocar primero el nombre de la función y esta debe estar seguida de sus argumentos que estarán entre paréntesis. Por ejemplo, abs(n) nos devolvería el valor absoluto de manera instantánea de la variable n.

Un punto a resaltar de las funciones es que todas devuelven un valor numérico del argumento evaluado, el cual a su vez tiene que ser un valor con ciertas restricciones según la función. Dentro de las funciones más usadas encontramos las siguientes:

funciones en PSeint ejemplos

Ejemplos del uso de operadores y funciones en PSeint

1) Dado un número que es ingresado  en segundos, convertir dicho número a minutos y segundos respectivamente.

Algoritmo ejemplo1
    Definir n,min,seg Como Entero
    Escribir Sin Saltar"Ingresa un número en segundos: "
     Leer n
     min<-trunc(n/60)
     seg<-n-(min*60)
     Escribir "Los minutos del número dado son: ",min
     Escribir "Los segundos del número dado son: ",seg
FinAlgoritmo

2)Realizar un programa que convierta los grados centígrados a grados Fahrenheit.

Algoritmo ejemplo2
    Definir centigrados,fahre Como Entero
    Escribir Sin Saltar"Ingresa los grados centígrados : "
    Leer centigrados
    fahre<-(centigrados*1.8)+32
    Escribir "Los grados Fahrenheit son: ",fahre
FinAlgoritmo

3) Realizar un programa que calcule el área de un circulo , una vez ingresado el radio del mismo.

Algoritmo ejemplo3
Definir area,radio Como Real
Escribir Sin Saltar"Ingresa el radio del circulo : "
Leer radio
area<-PI*(radio^2)
Escribir "El área del circulo es: ",area
FinAlgoritmo

4) Realizar un programa que reciba tres números reales y que determine cuál es el mayor de todos, para luego imprimirlo en pantalla.

Algoritmo ejemplo
Definir n1,n2,n3 Como Entero
Escribir "Ingresa 3 números a evaluar: "
leer n1,n2,n3
si n1>n2 Entonces
si n1>n3 Entonces
Escribir "El mayor número de todo es ",n1
SiNo
Escribir "El mayor número de todo es ",n3
FinSi
SiNo
si n2>n3 Entonces
Escribir "El mayor número de todo es ",n2
SiNo
Escribir "El mayor número de todo es ",n3
FinSi
FinSi
FinAlgoritmo

5) Realizar un programa que le pregunte al usuario un número del (1 al 10), para luego contar cuantas veces se encuentra dicho número en un vector aleatorio con números del (1 al 10)  y con 20 datos.

Algoritmo ejemplo5
Definir vector, i,num, cont como entero;
num<-0;
cont<-0;
Repetir
Escribir Sin Saltar "Ingresa el número a evaluar de (1-10): ";
Leer num;
Hasta Que (num>0 y num<11)
dimension vector[20]
para i <- 1 hasta 20 con paso 1 Hacer
vector[i] <-azar(10)+1;
Escribir sin Saltar vector[i] " ";
FinPara
para i <- 1 hasta 20 con paso 1 Hacer
Si(vector[i]==num) Entonces
cont<-cont+1;
FinSi
FinPara
Escribir " ";
Escribir Sin Saltar "Cantidad de veces que esta el número en el vector: ";
Escribir cont
FinAlgoritmo
Déjanos tus comentarios:
Artículos Relacionados: